Close



Page 1 of 3 123 LastLast
Results 1 to 25 of 71
  1. #1

    Default Fixin' Stuff on my 84 GT Turbo

    Replaced and fixed some stuff on my gt turbo vert.





    Replaced the PIP sensor and cleaned it up some on this junkyard distributor while i was at work so i can pull the original and rebuild that. Hopefully tomorrow ill get around to that.







    Replaced the old coil with an original one.






    The old TFI and idle air solenoid.




    Last edited by 1984GTTurboVert; 09-23-2022 at 10:17 PM.

  2. #2
    FEP Power Member ccurtin's Avatar
    Join Date
    Apr 2009
    Location
    Acworth, GA
    Posts
    1,461

    Default

    Nice, lots of good maintenance. While you have things apart how old is the fuel pressure regulator? I had mine not be able to hold up to the 255 pump and had to replace it. I don't think it was original, but it was at least a decade old.
    I'm an FEP Paid Supporter and proud of it. Are you?

    1984 Capri Turbo RS - Alive after 7 years! Build Thread
    2018 Mustang GT - daily driver

  3. #3

    Default

    I can only assume its original, i havent gotten to checking anything fuel related since some work was done before i got it on that. I replaced the turbo and exhaust manifold with nos parts except for the exhaust manifold bolts since i couldnt find them, and it took forever to locate a decent correct t3 oil return line. I wound up finding one after i put it back together and i really aint in the mood to go thru that again right now(maybe over the winter ill put it in).

  4. #4

    Default

    Does anyone know if the t5 shifter in these cars are specific to them?
    When i first got the car the shifter arm was so close to my leg i couldnt even shift it properly, so i assumed they bent it for a much smaller person to use it(they didnt). It had a bad shifter cup bushing and i bought a cheap short shifter that was more upright to replace the whole thing.






    But, the car wasnt drivable then so i didnt get a chance to try it out untill recently and i hated the way it shifted so i removed that and reinstalled the original. After making a spacer to move the arm further away its tolerable now but i went and looked at some pics of t5 shifters and never saw these bent in this manner, except when looking at these specific turbo cars, not svo since they have a different shifter arm from what i saw. But, not all of them had it in the pics i could find, none of them had the flat of the shifter facing away from the driver like mine either. I read people flip them but when i had it out i can definately say they never bent the tabs to dismantle it and flip it around the other way.
    My 91 4 banger t5 wasnt bent to the side like this one is.

  5. #5
    FEP Power Member
    Join Date
    Nov 2007
    Location
    San Mateo, CA
    Posts
    2,265

    Default

    The shifter should be common to all of the other period mustangs. Usually the rubber bushings melt and the handle gets loose. Mine seemed to be a reach because I have the seat extenders putting me further from the dash.
    Fox Body/3rd Gen MCA Gold Card Judge
    84 SVO 24K miles, 85 Mclaren Capri Vert. 84 GT Turbo Vert.
    88 Mclaren Mustang Vert 20K miles, 89 Mustang LX Sport Vert,
    03 Mach 1 7900 miles, 74 Mustang II, 69 Mustang, 67 Mustang, 07 GT500,
    14 Mustang CS/GT, 15 F150 FTX Tuscany, 16 F250 Crewcab, 67 Tbird 47K miles

  6. #6

    Default

    Its really hard to describe properly just looking at it, i shouldve taken a picture of it in action.
    Its like taking the shifter arm and bending it towards the driver to the point where shifting into 1st and 2nd has your thumb grinding against your thigh. The shifter and springs itself isnt broken and the cup inside isnt worn.
    Very unnatural feeling but after putting a 3/4" spacer on the shifter arm to shifter stalk its manageable now.

  7. #7
    FEP Power Member ccurtin's Avatar
    Join Date
    Apr 2009
    Location
    Acworth, GA
    Posts
    1,461

    Default

    Do you have a broken motor mount or transmission mount? Leaning that far to the left is unusual. Is the shifter itself parallel to the transmission tunnel or angled to the driver's side? Hard to tell from your pictures.
    I'm an FEP Paid Supporter and proud of it. Are you?

    1984 Capri Turbo RS - Alive after 7 years! Build Thread
    2018 Mustang GT - daily driver

  8. #8

    Default

    I know the pics are terrible i apologise the shifter base itself seems basically center in the trans tunnel hole for it, the shifter arm is very bent towards the driver.
    Ill have to pull the center console back out and take a few pics next time.
    I didnt see any broken motor mounts while under the hood, ill have to look at the trans mount next time im under the car.
    Thatll have to wait untill i do something about the alternator harness, its in bad shape im not putting this back in like this.




  9. #9

    Default

    Wasnt going to mangle the connector to pull the whole wire out so cleaned everything and used shrink tubing and one of those water tight connectors with solder in it already to repair it. Ill touch it all back up with liquid electrical tape just cause.
    Tested continuity on all wires and its fine. Later on i may make a whole new thing for it just for safety reasons.




  10. #10

    Default

    Went back to the garage today to finish putting in the distributor.
    Followed the instructions on figuring out your timing from this video(https://m.youtube.com/watch?v=wElr-Y0Ko) recommended to me in the "i need help" thread i recently started.
    Took the timing cover off to see where everything was at.






    I replaced the TFI on the rebuilt distributor again, this time with a nos dy-425 i picked up recently and put it in.
    I left my oil pen to mark positions at home so i stole a swab of the heatsink stuff off the TFI i took off and marked the distributor #1 and position of distributor with it, it got me where i needed to be.
    Reinstalled the timing cover, alternator bracket and alternator and distributor hold down and plugged everything back in(except the spout) and went to start it.
    Started up and stayed running long enough to start twisting the distributor and finding a good spot.
    My timing light was completely unusable so i played it by ear, ill pick up another one.
    Once it got running it was surging so i replaced the new idle air solenoid with the original one i cleaned up some and it finally runs good now.







    I cant really find the "right way" to run the plug wires over the motor but under the intake like it shows in all the books i went over, aesthetics but its bugging me something awful.
    I ran it and revved it up many times but it took over 30 minutes for the temp to go up enough to turn the fan on. It took about 5 last few times i tracked the fan to see if its working.
    I cant really tell if its the ambient temp being cooler or its actually running cooler now. Reminds me that i got to flush this ones coolant and replace the thermostat.
    Last edited by 1984GTTurboVert; 10-01-2022 at 08:47 PM.

  11. #11

    Default

    I had a day off work and tried to make some time to atleast fix something on one of my cars, so i stopped by and decided to replace the bad fog light switch and relay that just happened out of nowhere awhile ago.





    I still have one bulb not lighting up so i got some new 55w halogen h2 bulbs coming and in 20 minutes my foglights should be working as they should.
    I also got around to replacing the drive belts since the old ones were splitting on the bottom and pulled the a/c belt since that aint worked in almost 20 years apparently.



    The original belts number?



    Im also pulling the original radio out, since the drivebelt to the tape player is gone and it cant hold a station very well, and replacing it with something from "the period" that wont look out of place like a modern aftermarket radio and should fit without trimming anything. Im not all commited to having bluetooth and the like and honestly a tape adapter is enough for me, provided the tape player works.
    Ran it for a bit and got white smoke out the exhaust that never really cleared up, but its been sitting for awhile and it was cold in the garage so i dont want to assume too much but im getting a test kit for the coolant just in case.
    Hopefully its nothing and im being paranoid because i never drive it.
    Last edited by 1984GTTurboVert; 01-17-2023 at 02:14 AM.

  12. #12

    Default

    Quote Originally Posted by 1984GTTurboVert View Post
    Im not all commited to having bluetooth and the like and honestly a tape adapter is enough for me, provided the tape player works.
    Word of advice, don't use a ****ty tape adapter.

    Grab yourself one of these bad boys if your antenna is still hooked up and decent. Works wonderfully in my car with the original cassette deck. I've had FM adapters that weren't worth a crap years ago, but they have really come a long way. Cheap and effective.

    https://www.amazon.com/SmartCharge-B...2-d605505c9d1e
    1986 Mustang GT - 2A, 5 Sp
    2018 Subaru WRX (Daily)

  13. #13

    Default

    So i went back to the garage today to fix a few things, or atleast that was the plan.

    My top doesnt fit right and is almost impossible to latch so i pulled the rear interior out to get to the top adjustments.



    One of the bolts wasnt where it was supposed to be for some reason, meaning im not the first one thats been in here.






    I have no clue what that plug near the seatbelt is for in the one pic on the passenger side, wire color was like black with green dots and i think orange or red with blue stripe, plug is corroded but can be cleaned.
    What i didnt do was take a pic of the "literal" mountain of sunflower seeds that was under the rear seat, well over 2 pound of them conveniently stored there(and in the spare tire area i cleaned out awhile ago) but not much shredded fabric by i assume some mouse. I can only hope that was from before i got it because i havent seen any mice in the garage but you never know. What i DIDNT find but was hoping to was the build sheet, checked everywhere at this point but on top of the gas tank. Bummer.
    Anyway...
    Failed to get the top sitting right so i moved on to other things.
    Namely tackling some maintenance and the white smoke situation.
    Even though i only ran the car for a few seconds at a time to charge the battery every time i played with the top the radiator cap had lots of pressure being held back when i opened it. Upper radiator hose was stiff as well So i left the radiator cap off to observe if i get any bubbles/crud or just anything odd while i ran the car during messing with the top. The radiator cap was a nos correct part but im wondering if it is bad out of the box now.
    Nothing on the radiator cap or oil cap indicating a blown head gasket, the overflow wasnt getting anything before despite all that pressure but now without the cap on it was, no more white smoke either but it was much warmer in the garage this time than last.
    Since i had it in the trunk and its easy to get to i went to change the thermostat and housing so could feel like i got something done today.
    Just remove the water pump pulley with a 1/2 wrench for the bolts, 9/16 for the alternator stuff to remove the belts, disconnect the hoses and a 10mm socket for the housing bolts and... SNAP, broke the top one off. Had plenty of soakings with pb blaster before the attempt but i knew i was going to pay at some point for getting all the header bolts out without breaking one.



    Despite the way it looks in the pic there isnt any indication of a milky substance anywhere in there.





    Old one compared to the new nos one with a cast housing i have to replace the original. Might look for another metal housing if i dont get back to this next weekend.



    I didnt have anything to drill out the broken bolt there and it was getting late so i called it a night. Now i have to get my drills, gun and find new bolts to finish that job. Atleast its easy to get to.

  14. #14

    Default

    Quote Originally Posted by ITdude87 View Post
    Word of advice, don't use a ****ty tape adapter.

    Grab yourself one of these bad boys if your antenna is still hooked up and decent. Works wonderfully in my car with the original cassette deck. I've had FM adapters that weren't worth a crap years ago, but they have really come a long way. Cheap and effective.

    https://www.amazon.com/SmartCharge-B...2-d605505c9d1e
    I am very skeptical of these considering how cheap they have become over the years. Is the quality there?
    I had an fm transmitter back when they cost some money and its performance was so-so at best. These newer bluetooth ones i have no experience with.

  15. #15

    Default

    Quote Originally Posted by 1984GTTurboVert View Post
    I am very skeptical of these considering how cheap they have become over the years. Is the quality there?
    I had an fm transmitter back when they cost some money and its performance was so-so at best. These newer bluetooth ones i have no experience with.
    Totally understand. I used to be the same way. They used to be junk, but the last one I picked up (haven’t had a need for one in many years) actually works quite well. They’re pretty cheap too. They’ve come a long way. Stick to Anker brand IMHO.

    Tape adapters just look and feel sloppy, plus most iPhones don’t come with a 3.5mm jack - you’d need to run two separate adapters. Yuck.
    1986 Mustang GT - 2A, 5 Sp
    2018 Subaru WRX (Daily)

  16. #16

    Default

    Today i went back to try to finish replacing the thermostat.

    Assembled the necessary parts to drill out the broken bolt.



    Didnt have a center punch to get a decent start and my screwgun was barely fitting in there, since the bolt was broken above the surface and had a step to it i had to hope i drilled it straight and center, close but didnt :P.
    The cheap harbor frieght easy outs were worthless and wouldnt grab the bolt so into the trash theyll go.
    The one time i had a bottoming tap and wished i had a regular one because all it did was push the scraps to the back instead of cutting into them.



    Oh well, if it doesnt hold in the long term ill drill it up a size and retap it since i dont need to remove anything to get this one.



    I tested the new thermostats action with a heat gun the other day, the old one had gouges and scrapes on it from dragging on the side during use so it was definately time to change it.







    Need a new hose clamp for the outlet since this one came apart when i took it off.

    After letting it sit for 2 hours to cure i torqued it up and ran the motor to see if it held up. No leaks so thats good but i might redo that bolt regardless.
    The radiator and watching the water flow in it however was a different story. Definately clogged, water spraying out the tubes like faucets on full blast just idling the motor with the cap off before it fully warmed up. Can see where all the pressure is coming from so im getting a new radiator for it, modern flow hopefully not a plastic endtank junk if i can find an aluminum one that doesnt look like some guys welding project i can paint to look stock.
    Since im going to restore and declog the one in my tbird ill just add this to that pile when i have the time for it to salvage it.
    Last edited by 1984GTTurboVert; 03-18-2023 at 09:58 PM.

  17. #17

    Default

    When i go back to fix that bolt again since the old water outlet cleaned up pretty nice with just brushing it, think im going to repaint it and put it back on.







    Feels alot more stought than the cast one and i have like 5 more gaskets left in the pack so why not.

  18. #18

    Default

    Stopped by today to do some work on the mustang.
    Was going to put in the new aluminum radiator and brackets i got for it, but decided to basically pull the motor apart to check the head condition instead.

    Started by pulling of the alternator, bracket and waterpump pulley and water outlet to get to the timing belt and undo that.






    Then, after i had the front taken care of i moved to the intake side of things. The center bolt on the upper intake under the fuel lines is a pain to get at if you try to short job it like i was, need to make a wrench that will fit in there better before i put that back in.






    I had to cut the return line at the connector on the pulse tranducer thingy because i couldnt get the fitting off, just plain wouldnt go. Not a big deal.




    Off with the lower intake, a little bit of sludge in the coolant passage it looks worse in the pic than in person.
    Finally got to check out the air/oil seperator properly since you got to go this far to even get to it and its not as bad as it looked before. Guess ill just flush it out for good measure and clean it up.

    Unbolted the exhaust manifold and pulled the valve cover off.






    Looks cleaner than i was expecting, maybe im crazy but i thought there was a ford casting number inside the valve area, all i saw in there was that tag, number 9 and "cTp" whatever that means.
    All i had to do now was break the headbolts loose but i didnt have a breaker bar on hand and the ratchet i had just isnt up to the task, broke my cheater bar trying so i sprayed them down with free all and called it a day.
    Ill come back later with the right stuff and finally pull this thing so i can get it checked for cracks.
    Now i have a bag and storage tote full of parts i pulled off today i have to go thru so i can clean up and replace what i can on them before i put it back together. Then ill try cleaning up the motor area and checking the state of the wires.
    Kinda sucks because it feels like winter is over and its getting close to driving weather and now i have a non running car but these things need to be done. Hopefully i can get back to working on the convertible top situation soon as well.
    Last edited by 1984GTTurboVert; 03-31-2023 at 09:12 PM.

  19. #19
    FEP Super Member gr79's Avatar
    Join Date
    Jun 2009
    Location
    SE Michigan
    Posts
    5,134

    Default

    Gosh those cam pics remind me of last year's valve stem seal replacement with engine in car.
    Was another job to do slow and steady with correct tools, lighting, and no mistakes allowed.

    And that same darn tstat bolt. Had to clearance the alt brkt on my 2.3 Ranger to get a socket on it.
    Had a mystery coolant leak. Replaced the rusty housing. Still had trace of coolant on the front coil pack.
    Found the upper rad hose had a pinhole leak. Only leaked when tstat opened and engine was running.
    No drips just a tiny stream jet of coolant was hard to see but could smell it.

    I use Permatex Hylomar for sealing items like t-housings, trans shifter assy to trans.
    Is a tacky blue gel, never hardens. No waiting for anything to set up. No problem removing parts and gaskets later.

    Long ago remember cracking the cast t-stat housing ear on my '67 289 engine.
    After that, bought my first torque wrench. The sure way to know a bolt is correctly tight.
    Tight enough is always a guess without one.
    Last time i did the Mustang's 2.3T's tstat, it seeped even after using a torque wrench.
    At first, went with the middle torque number in the spec window.
    Snuck the torque up a couple more pounds to max spec and all is well. Could never do that without one.

  20. #20

    Default

    Guess i was lucky that this one didnt leak before i pulled it back off considering i didnt use a torque wrench on it and the upper bolt barely held.
    I did use springlock washers though.

  21. #21
    FEP Power Member ccurtin's Avatar
    Join Date
    Apr 2009
    Location
    Acworth, GA
    Posts
    1,461

    Default

    Did you loosen the exhaust manifold bolts before trying to loosen the head bolts? The upper row intercepts with the head bolts so there is a change they are acting as 'set screws' on the head bolts. I broke off a head bolt taking apart my donor engine because I didn't know that.
    I'm an FEP Paid Supporter and proud of it. Are you?

    1984 Capri Turbo RS - Alive after 7 years! Build Thread
    2018 Mustang GT - daily driver

  22. #22

    Default

    Yes, the exhaust manifold bolts were already out before i tried. Thankfully when i replaced the original manifold i didnt break any of those, oh man what a pain that would be to fix without removing the head.
    It was just a case of too little ratchet for the job and my cheater bar "was" my distributor wrench, i say was caused i broked it. I couldnt find my actual breaker bar at my other garage today but i did find my 12" long 1/2 drive ratchet i typically use for wheel lugs and such jobs and my 1/2 drive deep sockets so next time i stop there i should be fine.

  23. #23

    Default

    Got my replacement cylinder head yesterday.






    Was expecting an 83-86 head since thats what i actually ordered. Beggars cant be choosers and is supposed to be crack free so thats all that matters.
    I absolutely hate how everything thats remanufactured i get looks like its been spraypainted in someones garage instead of hot tanked or cleaned.
    Im going to leak test the valves before i throw it in just for peace of mind since i aint the guy that assembled it.
    Im still waiting on new cam, lifters and followers to have a complete ready to go head to swap in. The only thing ill have to reuse from the old head is the plate for the cam since i cant find one.
    I have 2 head gasket sets to pick from but not sure which one ill go with on assembly.
    Got a replacement for the radiator fan assembly thats oem since the one on the car isnt and it bothers me, going to put a new motor on it because they are cheap and put a nos fan controller i picked up for it as well. Still got to paint the new radiator i got but thats going in last after i replace this head.
    I replaced the screens, o rings and pintles on the injectors(the old screens were perfectly clean but why not) , replaced the fuel pressure regulator on the rail while i had them out and generally cleaned up everything i could with a brush while i had it out so can repaint them before putting them back.



    Got lots of parts waiting to be replaced but need to get me lots of time to get this thing finished up and running again.
    Last edited by 1984GTTurboVert; 04-16-2023 at 03:34 AM.

  24. #24

    Default

    Getting closer to getting this thing up and running again.
    The other day i bought a 5 gallon bucket parts washer to clean up what i can since i dont have the room for something useful, they didnt come out that bad with just hot watered down purple power and a brass brush.








    Lighting aint helping since it was 5am, they look nicer in person and i blasted what carbon i could out of the intake with that paint spray cleaner they sell at harbor freight. The EGR passage was completely plugged solid with crud and needed stabbings with a coat hanger just to chisel thru it.

    Today i went back and pulled the head off to bring home and swap the small stuff over and go over it to see what happened.

    The block.











  25. #25

    Default

    I didnt know there is an image limit, ill have to cut back some.

    The head.







    With the gasket removed.







    The old gasket, part number e59e-6051-a5a.










    At a glance there isnt anything showing the gasket is blown, some seepage at the rear and the headbolts for cylinders 2&3 on the exhaust side were rusted pretty bad(thankfully ther didnt break and hopefully the holes are ok). Why is the design of the gasket purposely blocked there? Wouldnt you want more cooling in that area?
    Cooling passages werent that cruddy, radiator looked worse on the inside than the head does.
    I had to break the oil feed line to the turbo since the fitting is seized to the oil sender fitting, i have a nos new one to replace it with i got when i did the turbo but never got around to replacing it then. I hate breaking stuff but atleast i have a replacement.

    Ill get the tools here to break down the head to check for cracks later this week.
    Last edited by 1984GTTurboVert; 04-24-2023 at 01:59 AM.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •