Close



Results 1 to 9 of 9
  1. #1

    Default 4G Alternator and Stock Zephyr Dash?

    Hello,

    I have a 4.6 4v in my 79 Zephyr. It has a 4G alternator. I want to keep the stock dash and gauges (idiot light, no ammeter).
    I bought the PA Performance 3G swap voltage regulator, but the instructions are not very clear.

    The alternator harness that came with the PA performance regulator has 3 wires. White, yellow, and green.
    My stock 4G alternator harness does not have the white wire, it only has the yellow wire, and green/red wire.
    I know the 3G uses the white wire with the small plug.

    The 4G harness yellow wire goes to a 30a fuse, and then to the power distribution box. The green/red wire goes to the charge indicator lamp.

    Could it be as simple as connecting my 4G green/red wire to the Zephyr LG/R wire to make the charge indicator lamp go out and allow the alternator to charge?
    I know there aren't a ton of people here with modular swaps, i have been searching the net but it seems most that do modular swaps, also swap in a late model dash and gauges.

    Any feedback is greatly appreciated. The car is not running yet but should be running shortly. Once the car is running i can test this out but would like to get this sorted out beforehand if possible.
    thanks and have a nice day.
    79 Zephyr, 4v/4r70w swap, with team z front and rear suspension, 8.8 and upgraded brakes and coil overs.

  2. #2
    FEP Power Member gmatt's Avatar
    Join Date
    Jul 2009
    Location
    Chicago, south subs
    Posts
    2,033

    Default

    I found this diagram on a google search:
    Hope that helps.

  3. #3

    Default

    Thanks for the speedy response!
    I think that is what i was going to do, i am hoping that the IC voltage regulator in the Zephyr dash will jive with this.
    I do have a spare but i don't want to fry anything.
    79 Zephyr, 4v/4r70w swap, with team z front and rear suspension, 8.8 and upgraded brakes and coil overs.

  4. #4
    FEP Power Member gmatt's Avatar
    Join Date
    Jul 2009
    Location
    Chicago, south subs
    Posts
    2,033

    Default

    I installed a 3G in my 80 Fairmont using the kit from PA performance and the 'dummy' regulator. No issues, works great.

  5. #5

    Default

    Quote Originally Posted by gmatt View Post
    I installed a 3G in my 80 Fairmont using the kit from PA performance and the 'dummy' regulator. No issues, works great.
    That is great to hear, thanks! Do you have a Modular engine?

    So i I'm going to do some additional research, but i have a feeling that this may not work with the stock idiot light. I think the 2 cars might work opposite from each other.
    79 Zephyr, 4v/4r70w swap, with team z front and rear suspension, 8.8 and upgraded brakes and coil overs.

  6. #6
    FEP Power Member gmatt's Avatar
    Join Date
    Jul 2009
    Location
    Chicago, south subs
    Posts
    2,033

    Default

    No, I have a 302, but the alternator doesn't know that. My dash light stays off.

  7. #7

    Default

    Quote Originally Posted by gmatt View Post
    No, I have a 302, but the alternator doesn't know that. My dash light stays off.
    Do you remember where you connected the G/R wire from the PA alternator harness?
    Thanks
    79 Zephyr, 4v/4r70w swap, with team z front and rear suspension, 8.8 and upgraded brakes and coil overs.

  8. #8

    Default

    So it looks like everything will work fine.

    I tested the connections at the instrument cluster with the key on. R/LG wire tested at 11.6 volts (slightly less than 12v) and the LG/R on the other side was grounded. Which seems to be what the circuits call for.
    Temporarily installed the instrument cluster, to complete the citcuit.
    Key on, the alt light comes on. I have 12v at the LG/R wire at the PA voltage regulator, which is correct for both the stock fox and the donor car.
    Used the power probe to apply 12v to the LG/R wire at the regulator, and the light went out.

    I am happy with that, was way easier than i thought.
    I ended up not even using the PA performance alternator harness. Didn't even need it.
    Thanks everyone for all the help, much appreciated!
    Last edited by massacre; 10-19-2021 at 10:37 PM.
    79 Zephyr, 4v/4r70w swap, with team z front and rear suspension, 8.8 and upgraded brakes and coil overs.

  9. #9

    Default

    Just as a slight update-
    All of the fox gauges are working. I just used the fox oil and coolant senders on the modular. "Engine" and "alt" light go out with the car running. Gas gauge also works. Very happy about all of this.
    79 Zephyr, 4v/4r70w swap, with team z front and rear suspension, 8.8 and upgraded brakes and coil overs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •