Close



Results 1 to 3 of 3
  1. #1
    FEP Power Member fgross2006's Avatar
    Join Date
    Sep 2014
    Location
    Freeport NY
    Posts
    1,845

    Default Front marker LED's malfunctioning

    On my 84 convertible I updated all my lights to LED's except for the headlights.

    I just noticed the other night when I was picking up Chinese food that the front markers/directionals malfunction when the headlights are on but the directional works fine when the headlights are off.

    headlight on - right directional is very dim, left directional doesn't light at all.
    headlight off, both directionals light at full power.

    Watch this vid and let me know if anyone knows why this is happening.


  2. #2

    Default

    Guessing you only added the lights and not the led specific relay ?

    (not being critical , I was actually wondering if anyone did it successfully without one)
    84 20th Anny 2.3Turbo #1978
    84 Turbo GT 11.70@120MPH 418RWHP
    89 41X Coupe 2200 miles
    96 Mystic Cobra Terminator swap

  3. #3
    FEP Power Member fgross2006's Avatar
    Join Date
    Sep 2014
    Location
    Freeport NY
    Posts
    1,845

    Default

    Quote Originally Posted by GT350R View Post
    Guessing you only added the lights and not the led specific relay ?

    (not being critical , I was actually wondering if anyone did it successfully without one)
    I put in 2 LED specific directional blinkers. One for the directional, one for the 4 way flasher.

    Seems fine unless the headlights are on. Also FYI, no problem with the rears at all.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •