Close



Results 1 to 2 of 2

Hybrid View

  1. #1

    Default 86 2.3 carbureted high idle issues when warm plz help

    Hows it going everyone, the issue Im having is the car idles high when warmed up, when cold it starts right up and idles at around 900rpm, But the idle will go up with the temperature, and once at operating temp it idles around 2000rpm, if I cap the carb it will turn off so I dont think I have that bad of a vacuum leak if any, if I disconnect the map sensor after a few seconds itll idle down to 1200ish rpm, if I rev it up it will hold the idle at 2k, then after a bit it will lower to around 1200rpm again, only with map sensor disconnected, with it connected it will not idle down ever, the car also doesnt do anything when I unplug the iac or the tps, this is my first 4eye and first carbureted car guys so please bare with me, any help will be greatly appreciated

  2. #2

    Default

    A leak around the butterfly rod may be your problem. Spray a little cleaner around it while running and see if things clear up. If so, replace the rod with a slightly bigger diameter...if available. I am a carb guy from the dark ages (76 years) and still like carbs. Putting a 2100 Autolite on my 2.3 in a sports car. NO COMPUTERS on my cars...yet, my degree is in electronics...go figure! I think I just got tired of chasing electrons after 20 years working on TV's, satellites, radios and such.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •