Close



Results 1 to 12 of 12

Thread: Brake Lights

  1. #1
    FEP User Vettn71's Avatar
    Join Date
    Aug 2016
    Location
    North Richland Hills, TX
    Posts
    86

    Default Brake Lights

    My brake lights have quit. They were working, because the car passed inspection. Itís an 84 GT. Anything besides bulbs or fuse

    TIA

    kJom

  2. #2

    Default

    Check your brake light switch. Use a test light and check for power to switch and push pedal down and check for power out of switch. It is located on your brake pedal towards the top.
    1967 mustang coupe -sold
    1967 cougar GT - sold
    1984 Mustang L 5.0L - Totaled
    1984 Mustang GT 5.0L
    2007 Mustang GT convertible ( wifes car)
    1997 F-350 powerstroke
    USMC Retired 1981-2001

  3. #3
    FEP User Vettn71's Avatar
    Join Date
    Aug 2016
    Location
    North Richland Hills, TX
    Posts
    86

    Default

    Yes, I just replaced the switch. Looks like it’s time to inspect every wire.

    Thanks for your help
    jim

  4. #4
    FEP Super Member gr79's Avatar
    Join Date
    Jun 2009
    Location
    SE Michigan
    Posts
    3,701

    Default

    Ground wires can cause havoc

  5. #5
    FEP User Vettn71's Avatar
    Join Date
    Aug 2016
    Location
    North Richland Hills, TX
    Posts
    86

    Default

    10-4 to that. Iíll put that on my to do list

    Thank you
    Jim

  6. #6
    FEP User Vettn71's Avatar
    Join Date
    Aug 2016
    Location
    North Richland Hills, TX
    Posts
    86

    Default

    Fuse is good, but no power to the switch. Any ideas?

    TIA
    Jom

  7. #7
    FEP Senior Member Tigger's Avatar
    Join Date
    May 2009
    Location
    Portland Oregon
    Posts
    501

    Default

    I’d check your turn signal switch. Brakes lights went out on my 67 when I first got it and it was the turn signal switch that caused it. I believe power comes from there. Good luck to you.
    67 Mustang Coupe
    96 Tangerine GT
    86 Saleen #179

  8. #8
    FEP User Vettn71's Avatar
    Join Date
    Aug 2016
    Location
    North Richland Hills, TX
    Posts
    86

    Default

    Thanks. I replaced everything else.

    Jim

  9. #9
    FEP User Vettn71's Avatar
    Join Date
    Aug 2016
    Location
    North Richland Hills, TX
    Posts
    86

    Default

    I’ve got an 86 service manual. Not sure how close it is to an 84. It shows the wires from the brake switch going to a 14290, which I guess is in the steering column?

    jim

  10. #10
    FEP User Vettn71's Avatar
    Join Date
    Aug 2016
    Location
    North Richland Hills, TX
    Posts
    86

    Default

    My flashers work, I have power at the fuse. I have turn signal/multifunction switch ordered. What else can I check?

    TIA
    Jim

  11. #11
    FEP User Vettn71's Avatar
    Join Date
    Aug 2016
    Location
    North Richland Hills, TX
    Posts
    86

    Default

    Tigger and all, thank you for the assistance. I followed Tigger's advice and bought a turn signal multifunction switch. I now have brake lights!! Why Ford would run this through the trun signals I can't figure, but they did. Pretty easy fix. I removed the steering column covers and everything was right there.

    Name:  IMG_0095.jpg
Views: 11
Size:  102.8 KBName:  IMG_0096.jpg
Views: 11
Size:  115.6 KB

  12. #12
    FEP User Vettn71's Avatar
    Join Date
    Aug 2016
    Location
    North Richland Hills, TX
    Posts
    86

    Default

    The most difficult part of this was getting the turn signal lever out. It's held in by a retaining pin that should release when it's pulled. Mine would not release, so I wound up taking the old switch apart

    Jim

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •