Close



Results 1 to 14 of 14
  1. #1

    Default Slow left turn signal

    My passenger side turn signal works perfect. However, my driver side turn signal blinks but like 4 seconds in between. Anything to look at? I tried a new bulb in back didnt change anything. What should I look for?

  2. #2
    FEP Member Dave9052's Avatar
    Join Date
    Jun 2016
    Location
    Saint Clair MI 48079
    Posts
    371

    Default

    How is front bulb? Are front and rear bulbs lighting only flashing slowing?

  3. #3

    Default

    Front, back and indicator all flash slow. Didnt have a chance to replace front one but I have a whole new lens etc so Ill probably try that tomorrow.

  4. #4
    FEP Member Dave9052's Avatar
    Join Date
    Jun 2016
    Location
    Saint Clair MI 48079
    Posts
    371

    Default

    If they are all flashing, it is beyond my scope of knowledge. If front is flashing no need to replace that bulb. I am sure others on FEP will have a answer.
    Last edited by Dave9052; 11-15-2018 at 08:12 PM.

  5. #5

    Default

    Current causes the bi metal strip to grow and break contact in the flasher. If it is slow either your voltage is low or your resistance is high. Meaning poor ground or low circuit voltage.check your sockets and your grounds. I've seen wrong bulbs or bulbs installed wrong. You are going to need a good volt meter to chase this down

  6. #6

    Default

    Sounds like fun. Thanks

  7. #7

    Default

    Sorry I couldn't tell you, " fix this ". Its not impossible it will just take time and patience.

  8. #8
    FEP Super Member gr79's Avatar
    Join Date
    Jun 2009
    Location
    SE Michigan
    Posts
    3,542

    Default

    Fixed slow turn signal problem this summer. Driver's side.
    Sometimes would not even flash, sometimes ok. Very slow flash.
    DS running light intermittent. Brake too. All bulbs checked ok. Inner tail light ok most of the time.
    Console graphic display alerted me of a problem and helped diagnose which one.
    Traced to ds running light socket. Replaced it.
    Also replaced flasher. Installed the wrong one sometime in the past. Went with number from owners manual.

    Guess after 40 years, things need replacing.
    Hated to cut and risk a mistake, but socket was shot.
    Was easier than i thought.
    Was dealing with 6 wires. Looking closer, seen they double up into std 3 wire socket.
    Marked the pairs, cut, used butt connectors to install new 3 wire socket pigtail.
    Everything works like new again.

  9. #9

    Default

    Quote Originally Posted by 2nd chance cobra View Post
    Sorry I couldn't tell you, " fix this ". Its not impossible it will just take time and patience.
    No i understand 100% guess that was me hoping it was something stupid but with wiring it never is. Thanks guys.

  10. #10

    Default

    I replaced front park lens and bulb and after I was done now when I turn on signal they just light up and stay lit. Hazards work normal. Maybe an issue with the actual turn signal at column?

  11. #11
    FEP Power Member Bryan Knebworth's Avatar
    Join Date
    Sep 2010
    Location
    Lexington, MA
    Posts
    2,354

    Default

    Did you try replacing the Flasher? Sometimes we overlook the "obvious" https://www.partsgeek.com/rrg5wgj-fo...ad=11620898048

  12. #12

    Default

    Quote Originally Posted by Bryan Knebworth View Post
    Did you try replacing the Flasher? Sometimes we overlook the "obvious" https://www.partsgeek.com/rrg5wgj-fo...ad=11620898048

    Figured that mess up both sides am I wrong?

  13. #13
    FEP Power Member Bryan Knebworth's Avatar
    Join Date
    Sep 2010
    Location
    Lexington, MA
    Posts
    2,354

    Default

    Quote Originally Posted by jfruauff View Post
    Figured that mess up both sides am I wrong?
    My '66 had a similar problem to yours. Bought a brand new one at the corner parts store, installed it in like 2 mins. Problem solved.

  14. #14
    FEP Super Member gr79's Avatar
    Join Date
    Jun 2009
    Location
    SE Michigan
    Posts
    3,542

    Default

    A flasher has 2 separate circuits. 4 way and ts.
    On mine the 4 ways worked fine, ts no.
    Flashers are speced as to how many lights they run.
    Temp substituted my Ranger's flasher into the Mustang. Flashed too fast.
    Manual says #552. Picked several at the salvage yard.
    Commonly used mid 70's to 90's.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •