Close



Results 1 to 7 of 7
  1. #1

    Default Newbie! 1983 GLX Convertible

    Hi I'm Jeff just bought a new to me 1983 Mustang GLX convertible! Looks great, drives great! Once it finally starts I've had it 2 1/2 weeks and it's been to the mechanic now 3x to replace the park/neutral switch. Now they think the tranny might need a rebuild. It shifts perfectly IMO. In my 2 1/2 weeks with it it will either hard start when it's warm, then it graduated to when trying to start it doing nothing in Park or Neutral...No noises or anything just a dead key turning the ignition. Eventually it will start (perhaps after an hour...or once the AAA arrives. LOL) All the while the power accessories still work just fine, car simply not starting. Today I picked up the car from mechanic with new switch. Started right up like a champ drove it for about an hour making about 4 stops then the 5th time same old problem. Called the mechaninc, he told me to turn the key all the way to the starting position then shift through the gears while holding the key there. It started! But clearly that is no way to live.

    Name:  IMG_4104.jpg
Views: 40
Size:  192.7 KBName:  IMG_4096.jpg
Views: 40
Size:  69.6 KB

  2. #2

    Default

    Great looking car!
    My dad and I both have Ď83 GLX Convertibles. Theyíre great!
    Sounds like itís definitely a neutral start switch issue.
    My guess is either the switch on the trans is bad or the shifter bushings are worn and itís not all the way in park or neutral.
    I would be beyond shocked if you need to rebuild the transmission to fix this problem.



    Sent from my iPhone using Tapatalk

  3. #3
    FEP Member Dave9052's Avatar
    Join Date
    Jun 2016
    Location
    Saint Clair MI 48079
    Posts
    374

    Default

    Welcome! Nice looking car!!! Good looking dog also!

  4. #4

    Default

    [QUOTE=AldeanFan;1892770]Great looking car!
    My dad and I both have Ď83 GLX Convertibles. Theyíre great!
    Sounds like itís definitely a neutral start switch issue.
    My guess is either the switch on the trans is bad or the shifter bushings are worn and itís not all the way in park or neutral.
    I would be beyond shocked if you need to rebuild the transmission to fix this problem.


    Thank you for the response. The bushing might be the answer, seeing that it's had 3 Park/Neutral switches in 2 1/2 weeks! I forgot to add that the car once was in "Park" and started reversing...not rolling back mind you but actually reversing although the backup lights were not on on the tail lights. It only did that once. Do you think the bushing fix is a pretty easy job?

  5. #5

    Default

    It should reliably start from neutral

    hold the brake, pull it all the way to low. Hold the key to crank as you click from gear L through drivecand into nuetral. Somewhere around neutral it will crank.

    Or rig a push button. Battery to button, button to starter selinoid.

    havent seen a nicer looking 83 in the dark blue in a long time.

  6. #6

    Default

    Thank you for this advice. Rigging a button might be an interesting idea at that. The previous owner rigged a switch to turn the radiator fan on so maybe this would also work. I'll run it by my mechanic. I don't think I'd be able to do that myself. It drives as good as it looks. Neither are flawless but both are really good! Again thanks!

  7. #7

    Default

    Welcome to FEP.. Nice Horse and Dog...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •