Close



Results 1 to 7 of 7

Thread: 86 A/C Enigma

  1. #1

    Default 86 A/C Enigma

    So I read many threads and thought I found the issue. Apparently not. Forum User Error I am sure ;-)

    My A/C compressor does not engage. I pulled the A/C Cutoff Switch/Relay and jumped the red power wire to the black/green compressor wire and the compressor engaged. Problem identified! (or so I thought). Replaced the relay with a new one, compressor still won't engage.

    Did I chase the wrong part? Or did I get a rare "bum" one from the supplier?

    Any advice greatly appreciated.

  2. #2
    FEP Super Member
    Join Date
    May 2003
    Location
    Roseburg Oregon
    Posts
    3,061

    Default

    Are you sure the system has a full charge ?
    clowns to the left of me , Jokers to the right

  3. #3

    Default

    Good question. I was told when I bought it that it had been charged, but that it needed a switch. So that was the reason I acted on the cutoff switch. Now that I look into this further perhaps he meant the low-pressure switch? Not sure that is a DIY item if it is possibly under pressure? Can it be tested somehow, or is that a shop item?

    Thanks for replying, appreciate it

  4. #4
    FEP Power Member vintageracer's Avatar
    Join Date
    Sep 2008
    Location
    HILLBILLY HOLLYWOOD, Tennesse
    Posts
    1,847

    Default

    Low pressure switch on the accumulator screws on and off easily for replacement with the system under pressure.

    FIRST thing you need to do is to confirm that the system is STILL properly/fully charged and NOT leaking.

    Based upon your comments from the seller you are taking their word that the system was charged properly and still is charged properly. IF you find the system is low on Freon "I" suggest you open the system, replace the accumulator, orifice tube and all 10-12 system rubber O rings and then recharge the system.

    Low system gas pressure = LEAK!
    Last edited by vintageracer; 07-12-2018 at 10:30 AM.
    Mike
    Remember, "Drive Fast, Turn Heads, Break Hearts!"

    1995 Ford Powerstroke F350 "Centurion" STRETCHED Crew Cab Dually

    I like "Cut & Coach Built" vehicles!

    www.musclecardeals.com


  5. #5
    FEP Power Member
    Join Date
    Nov 2007
    Location
    San Mateo, CA
    Posts
    1,371

    Default

    Quote Originally Posted by vintageracer View Post
    Low pressure switch on the accumulator screws on and off easily for replacement with the system under

    Low system gas pressure = LEAK!
    Since you have some info that it was maybe ok, You can jumper the switch to see if that engages the compressor. Don’t run it long. There are 2 types of switches. One for R12 and one for R134.
    Fox Body/3rd Gen MCA Gold Card Judge
    84 SVO 24K miles, 85 Mclaren Capri Vert. 84 GT Turbo Vert.
    88 Mclaren Mustang Vert 20K miles, 89 Mustang LX Sport Vert, 92 GT Vert.
    03 Mach 1 7900 miles, 69 Mustang, 67 Mustang, 14 Mustang CS/GT,
    15 F150 FTX Tuscany, 16 F250 Crewcab, 67 Tbird 47K miles

  6. #6

    Default

    Thanks Vintageracer and Kevin, appreciate the info. I will check that out and go from there.

  7. #7

    Default

    I had a similar issue with mine. you might check the wire that supplies power to the low pressure switch. On mine it never did. I traced it back to the switch in the dash and found the wire between the A/c switch in the dash and the low pressure switch was broken. So I spliced in a new wire from switch in dash to low pressure switch. works great.
    When you have kids, you will find yourself saying things you'd never thought would ever need to be said. Ever. The other thing you will notice, is how often you will say them.....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •