Close



Results 1 to 5 of 5
  1. #1

    Default New Vintage dash or New dash users

    Has anyone had luck with the new vintage dash? Do the gauges work properly?
    What other options have people used autometer?

  2. #2
    FEP Supporter vdubn's Avatar
    Join Date
    May 2017
    Location
    Beaverton, Oregon
    Posts
    454

    Default

    I ran the New Vintage gauges in another vehicle, and although the gauges were nice, and seemed to work fine, I had more of an issue with how they mounted on the back side of the cluster. I noticed in the Fox Body cars, they mount the same way. It may work fine in the Fox Body, but in the other car I had, their brackets on the back side hit stuff behind the dash.

    I am currently running the Dakota Digital dash in my 85, but haven't hooked it up yet. My experience with other Dakota stuff, like their fan controllers, etc, is that they work excellent, and I found their instructions and tech support to be top notch.

    Here is the version I'm running in my car, mocked up behind my gauge panel:
    Name:  swap-parts3.jpg
Views: 169
Size:  127.5 KB
    85 GT Hatchback, T-Tops. 2012 Coyote 5.0L Swap, T56 Magnum, GT550 Dept of Boost kit, with Eaton M122 SC, RAM 11" Powergrip clutch, BBK Long Tubes/OR X-Pipe, Flowmaster Axle Back, Stifflers DS Loop, and Rear X-member, AJE Tube Crossmember with AJE-Mod Mounts, 3.73 Posi 8.8, 5 lug Cobra 13" fr and 12.6" rear disc swap, 2004 Hydroboost Swap, MM SubFrame Connectors, MM Panhard Bar, MM front A-Arms, MM rear control arms, MM CC Plates, MM Coilovers w/Koni dampeners, MM Torque Arm (soon to be installed).

  3. #3
    FEP Senior Member qikgts's Avatar
    Join Date
    Jan 2010
    Location
    Rockledge, FL
    Posts
    945

    Default

    I did the Dakota Digital Black Alloy setup...

    Name:  IMG_0700.jpg
Views: 150
Size:  106.0 KB

    Name:  IMG_0704.jpg
Views: 151
Size:  51.5 KB

    http://vb.foureyedpride.com/showthre...-Gauge-Cluster
    '85 GT

    The other one... 2016 F-150 XLT Supercab Ecoboosted with 3.73's...

  4. #4

    Default

    Did you splice and trim the existing loom to work? Or rewire it

  5. #5
    FEP Senior Member qikgts's Avatar
    Join Date
    Jan 2010
    Location
    Rockledge, FL
    Posts
    945

    Default

    I spliced where needed and ran the wires for the included oil pressure and temp sensors.
    '85 GT

    The other one... 2016 F-150 XLT Supercab Ecoboosted with 3.73's...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •