Close



Results 1 to 5 of 5
  1. #1

    Default Need Help.. 86 gt

    Ive got an issue with my instrument cluster. no lights come on. Ive replaced the dimmer switch all fuses. The gauges work and the lights for the hvac and the car outlay below the radio works. Ive did everything i can find and now im lost.

    parking lights and tail lights all work as well as headlights low and high beam.. just these dadgum cluster lights.

    Thanks for any direction you can point me in.

  2. #2
    New User
    Join Date
    Oct 2017
    Location
    south-central WY
    Posts
    24

    Default

    Sounds like you will need a wiring diagram and a volt meter for a start.
    Were the lights working and suddenly quit, or did the cluster lights fail one by one, or have they never worked?

  3. #3

    Default

    they didnt just quit one day.. they were getting weak and then they just wouldnt light up. but the problem was spread across everything. Hvac and the time was very dim as well. I replaced the dimmer switch and that solved the hvac and time as they light up bright now but i still have no gauge lights.. i hate electrical stuff.

  4. #4

    Default

    check the link in my sig. I've got the 86 electrical book I scanned a few years back. in the bottom of the zip file is the table of contents
    Jeremy
    -86 mustang SSP X CHP Unit # 3788-bone stock & staying that way
    -66 Mustang, bench seat car,8.8,t5 fuel injected 92 engine
    -72 Maverick 5.0 resto in process
    -12SS Camaro 6 speed. 600 FWHP, Kraftwerks Supercharger
    -03 z71 Avalanche 9" lift on 35s Daily Driven 20k a year. 290k miles at 11.8 mpg
    Entire 1986 electrical and vacuum troubleshooting manual download
    http://slantnosefox.com/picturehosti...g%20manual.zip

  5. #5

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •