Close



Page 1 of 2 12 LastLast
Results 1 to 25 of 29
  1. #1

    Default new guy from central TX

    hello guys!! I purchased my 84 GT a few months ago,then I came across this site and decided to join the 4eye family...Im hoping to get some good advices in what to do and what not to do with it...thank u guys!!!

  2. #2
    FEP Power Member STANGMAN116's Avatar
    Join Date
    Mar 2013
    Location
    DENVER CO, the 303
    Posts
    2,470

    Default

    Welcome to FEP!!!! lets see some pics

  3. #3

    Default

    Welcome to FEP!! Let's see some pics!!!

  4. #4
    FEP Senior Member dtmilsap's Avatar
    Join Date
    Mar 2015
    Location
    Rose Hill,Kansas
    Posts
    533

    Default

    Lots of pics, doesn't matter what condition your car is in. Lots of good advice on what to do and what not to do.

    Sent from my SAMSUNG-SM-G900A using Tapatalk

  5. #5
    Moderator wraithracing's Avatar
    Join Date
    Jun 2010
    Location
    Grand Junction, CO
    Posts
    10,647

    Default

    Welcome to FEP!

    I was just down in Hutto working at my old shop there off of 79. Back up here in CO for awhile and then I will be back down there the end of August! Hopefully it will have cooled off a bit by then!

    Now we need some pictures!
    ​Trey

    "I Don't build it hoping for your approval! I built it because it meets mine!"

    "I've spent most of my money on Mustangs, racing, and women... the rest I just wasted."

    Mustangs Past: Too many to remember!
    Current Mustangs:
    1969 Mach 1
    1979 Pace Car now 5.0/5 speed
    1982 GT Awaiting Restoration
    1984 SVO Restoration in Progress
    1986 GT Wrecked by PO, but still want to save!

    Current Capris:
    1982 Capri Roller
    1984 Capri Returned to Bubble Back Glory
    1983-84 Gloy Racing Trans Am/IMSA Body Parts

  6. #6

    Default

    Welcome to FEP... Like the rest of the fellows said... pics........

  7. #7

    Default

    thanks for the welcoming guys!!
    first thing i did was sand some of the surface rust and put primer and some paint butvran out (lol), and also put drop springs,
    the only thing I wanna mess with is the engine,put a roller ( I have one, just gotta rebuilt it)Name:  20170721_145226.jpg
Views: 76
Size:  74.5 KB

  8. #8

    Default

    thanks for the welcoming guys!!
    first thing i did was sand some of the surface rust and put primer and some paint butvran out (lol), and also put drop springs,
    the only thing I wanna mess with is the engine,put a roller ( I have one, just gotta rebuilt it)Name:  20170721_145226.jpg
Views: 76
Size:  74.5 KBName:  20170721_145210.jpg
Views: 69
Size:  78.9 KB

  9. #9

    Default

    I forgot to mention that I also change the front bumper, iI hope thats not a bad thing

  10. #10

    Default

    Welcome to FEP. That is what my 84 looked like when I bought mine white & Black with red interior. Nice looking car.
    Bob
    1967 mustang coupe -sold
    1967 cougar GT - sold
    1984 Mustang L 5.0L - Totaled
    1984 Mustang GT 5.0L
    2007 Mustang GT convertible ( wifes car)
    1997 F-350 powerstroke
    USMC Retired 1981-2001

  11. #11

    Default

    thanks Bob!! ,,your car is freaking awesome!!

  12. #12

    Default

    Welcome!

  13. #13

    Default

    Quote Originally Posted by Soulowd View Post
    Welcome!
    thank you!!!!

  14. #14

    Default

    I took those pictures of the car when I broke down at the CVS parking lot, (Im pretty sure Mr. Trey is familiar with that location.....) brakes locked up after driving it for a little while but they unlock after it cools off,,,,any ideas of wht can it be??,,thanks in advance!!

  15. #15

    Default

    Parking brake dragging. Boiling brake fluid? Don't ever use the parking brake after hard braking.

  16. #16

    Default

    Quote Originally Posted by Hammer Down View Post
    Parking brake dragging. Boiling brake fluid? Don't ever use the parking brake after hard braking.

    none of that,,,before I bought the car, the brake pedal was too low and I told the guy about it ,then he replace the M.C. maybe he messed with the BB rod,,?? ill mess with it this weeken n see wht hapens

  17. #17

    Default

    no luck today,,I adjust the BB rod but still is locking up,,,I loose the brake lines at the MC and it unlocked,,,,any sugestions????

  18. #18

    Default

    I had a car do that before and it was the rubber brake hoses that go to the calipers. They had started to disintegrate inside and the junk in them wouldn't let the pressure release. Maybe yours isn't cooling off, its slowly releasing the pressure.
    1978 Mercury Zephyr boxtop 5.0 EFI T5Z 8.8
    1999 Ford Contour 2.5 V6 5 speed
    2016 Ford Focus ST 2.0 Ecoboost 6 speed

  19. #19

    Default

    Quote Originally Posted by ukravit View Post
    I had a car do that before and it was the rubber brake hoses that go to the calipers. They had started to disintegrate inside and the junk in them wouldn't let the pressure release. Maybe yours isn't cooling off, its slowly releasing the pressure.
    Thanks for the reply!,,,I change the calipers and the rubber hoses,the master cylinder is new according to the previous owner,do u think is the Brake booster???

  20. #20

    Default

    You could check the things listed here,
    http://techtalk.mpbrakes.com/how-to-...ing-brake-drag
    1978 Mercury Zephyr boxtop 5.0 EFI T5Z 8.8
    1999 Ford Contour 2.5 V6 5 speed
    2016 Ford Focus ST 2.0 Ecoboost 6 speed

  21. #21

    Default

    Quote Originally Posted by ukravit View Post
    You could check the things listed here,
    http://techtalk.mpbrakes.com/how-to-...ing-brake-drag
    Im about to check it out,,,thanks!!

  22. #22

    Default

    Did the brake booster test and according to it I got a bad BB,,,but wht I dnt understand is why did the brakes didnt unlocked when I removed the MC from the BB,but they unlocked when I loosen the brake line nut that goes to the front brakes at the MC.....

  23. #23
    MurrayFeho
    Guest

    Default

    Boom Beach includes a tutorial worth watching, which educates lots of the basics of playing with this popular cellular video sport. Feel free to surf to my site - boom beach gameplay

  24. #24
    Moderator wraithracing's Avatar
    Join Date
    Jun 2010
    Location
    Grand Junction, CO
    Posts
    10,647

    Default

    As stated before, it sounds like you have a bad hydraulic rubber line going to the front brakes. The lines will deteriorate from the inside out, so they may look fine, but have collapsed internally. When you remove the brake line from the M/C that relieves the pressure and the brake(s) unlock just as you would normally release the pedal. I would recommend replacing both lines just due to age and the fact that both are too important and too inexpensive to not cover your butt in situations such as this. You are probably looking at $20 a side give or take at Oreilly, AZ, etc.

    I will be back down in TX by the 20th or so. Send me a PM and I will give you my contact information. You can stop by my ole shop in Hutto and I can help you out if needed. Good Luck!
    ​Trey

    "I Don't build it hoping for your approval! I built it because it meets mine!"

    "I've spent most of my money on Mustangs, racing, and women... the rest I just wasted."

    Mustangs Past: Too many to remember!
    Current Mustangs:
    1969 Mach 1
    1979 Pace Car now 5.0/5 speed
    1982 GT Awaiting Restoration
    1984 SVO Restoration in Progress
    1986 GT Wrecked by PO, but still want to save!

    Current Capris:
    1982 Capri Roller
    1984 Capri Returned to Bubble Back Glory
    1983-84 Gloy Racing Trans Am/IMSA Body Parts

  25. #25
    FEP Super Member bwguardian's Avatar
    Join Date
    Jul 2010
    Location
    Houston (Clear Lake), Texas
    Posts
    4,285

    Default

    Quote Originally Posted by 84zorro View Post
    Thanks for the reply!,,,I change the calipers and the rubber hoses,the master cylinder is new according to the previous owner,do u think is the Brake booster???
    Welcome fellow Texan! Did you also change the rubber hose in the back, over the axle? I had a similar problem with mine when I went through the car several years ago. Changed all three rubber brake hoses and A-OK after that.
    HAD
    '82 GT monochromatic (red)...black cloth

    HAVE
    '85 GT vert two tone (white on charcoal)...white leather
    '00 F350 two tone (white on silver)...gray cloth
    '00 Excursion Limited two tone (white on tan)...tan leather...wifes ride
    '08 Taurus Limited ice blue...tan leather...daughter ride

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •