Close



Page 4 of 4 FirstFirst ... 234
Results 76 to 100 of 100
  1. #76
    FEP Supporter

    Join Date
    Jun 2003
    Location
    Decatur Alabama
    Posts
    1,262

    Default

    Quote Originally Posted by quickerstang View Post
    update, I blew out the exhaust gasket, again . Thought I would drive it to work and getting on the freeway on the way home it was like boost then bam lots of noise. This is the third time I blew out that gasket.I think the turbo is ok as it still makes boost. Oh and it turns out I was only running 15lbs of boost and not 18lbs. LOL, I cant wait to get it to 20, that should give me at lease 25-30 more hp
    There is not suppose to be a gasket between the head and the exhaust manafold. It is metal to metal.
    Kendal

  2. #77
    FEP Member
    Join Date
    Jan 2011
    Location
    Brighton MI (Phila and Phoenix)
    Posts
    318

    Default

    Quote Originally Posted by KCoker View Post
    There is not suppose to be a gasket between the head and the exhaust manafold. It is metal to metal.
    I don't think this car is the "machined manifold to machined head" !! He is running a header so I assume this is using silver style NA gasket.

    Let us know IF you are continuing to try that one - OR IF you have gotten the Copper SCE or Esslinger style.

    Mark

  3. #78
    FEP Supporter

    Join Date
    Jun 2003
    Location
    Decatur Alabama
    Posts
    1,262

    Default

    Quote Originally Posted by TheSVOTrust-MarkHaas View Post
    I don't think this car is the "machined manifold to machined head" !! He is running a header so I assume this is using silver style NA gasket.

    Let us know IF you are continuing to try that one - OR IF you have gotten the Copper SCE or Esslinger style.

    Mark
    I didnt see that part.
    Kendal

  4. #79
    FEP Member
    Join Date
    Jan 2011
    Location
    Brighton MI (Phila and Phoenix)
    Posts
    318

    Default

    Quote Originally Posted by KCoker View Post
    I didnt see that part.
    It getting harder and harder to keep our own project straight -let alone others cars !! LOL

    I had to go back to earlier posts , download photos and blow up to see issue.

    Mark

  5. #80

    Default

    So I drove the SVO to work today cause I didnt feel like putting air in the new edge's tire this morning. I must say that that little car rips. It is still a loose as hell s*@tbox, but it gets sideways in second and barks 3rd. Now if I could just get rid of all the rattles and the dang sunroof that beats on my head

  6. #81

    Default

    Started the SVO after like a month and a half to take it for a spin and the fuel pressure seems very low. Like 15 lbs? When I burp the throttle it jumps to like 25-30lbs. Not sure if it is the sender in the autometer guage or what. I will have to hook up a mechanical to check for sure. Any suggestions, thoughts? It has been a while since I have drove it, and now I have to work on it before I can.

  7. #82

    Default

    update, I put a mechanical guage on it today and pressure is fine. Drove it down the street for the first time in a long time. I still love how when the boost comes on in second gear it gets sideways. Wish these things were not so damn tempermental. Maybe I would play with it more

  8. #83
    FEP Member Ford Builder's Avatar
    Join Date
    Nov 2008
    Location
    Chatham Ont Canada
    Posts
    409

    Smile

    That's great news glad it was something simple .
    IF ITS FORD POWERED YOU GOT TO LOVE IT

  9. #84

    Default

    Update, the SVO is getting some love. I am doing the torque box thing ,well you know why. This thing will be seeing the 1/4 mile coming up shortly




    btw, that sound deadning stuff is like friggin gasoline, first spark and I had a big ol fire in there

  10. #85

    Default

    Nice work my friend!! I'm glad your planning on getting in some quarter mile action with her. Can't wait to see some ET slips on what she will run, Good luck on your 1320 adventure!!!

  11. #86

    Default

    Quote Originally Posted by LilRed86coupe View Post
    Nice work my friend!! I'm glad your planning on getting in some quarter mile action with her. Can't wait to see some ET slips on what she will run, Good luck on your 1320 adventure!!!
    thanks, I will post time slips and videos

  12. #87

    Default

    put the interior back in it today.


  13. #88

    Default

    was playing with the svo today
    this is what happened




  14. #89
    FEP Member Silver83's Avatar
    Join Date
    Jan 2006
    Location
    Murfreesboro, TN
    Posts
    294

    Default

    I hate when that happens... Looks great!

  15. #90

    Default

    Had a little play time in the SVO
    https://www.youtube.com/watch?v=NYDdjYfKqcs

  16. #91
    FEP Super Member JTurbo's Avatar
    Join Date
    Jan 2006
    Location
    Western MA
    Posts
    5,560

    Default

    Love the sound of the turbo during spool down....
    1979 Indy Pace Car Mustang 302 / 5spd
    1982 Mustang GT T-Top 302 / 4spd - finally under the knife for a resto:
    http://vb.foureyedpride.com/showthread.php?t=121124
    1986 SVO Mustang - 1C
    1986 Mustang GT Vert 302 / 5spd

  17. #92
    FEP Super Member PaceFever79's Avatar
    Join Date
    Feb 2009
    Location
    Western PA
    Posts
    9,618

    Default

    Almost hit that dumpster!?

    I'm curious where you got the replacement turbo?

    Makes me want to go work on mine!

  18. #93

    Default

    Quote Originally Posted by PaceFever79 View Post
    Almost hit that dumpster!?

    I'm curious where you got the replacement turbo?

    Makes me want to go work on mine!
    I had it built by the guy at performance techniques in san bernadino, ca. It is a t3/t4 hybrid. I can provide the specs later if interested
    Last edited by quickerstang; 10-28-2014 at 07:06 PM.

  19. #94

    Default

    Ok, I just thought I would update you guys on the running aspect of my SVO

    I was having problems keeping it running smooth, iratic idle, stalling just running like crap and it has been diong that for a long time. Every once in a while the car wouldnt start. So I put a volt meter on it and it was running at 12.5 volts at idle and revving it up also. Then the fan came on(I have a supercoupe fan and radiator due to the big ass intercooler), when the fan came on voltage dropped to 11.5. I think I found the cause and I installed a 3g Alt. and sure enough car ran smooth, idled great and didnt want to stall after I get on it and push in the clutch( well most of the time). I also found that when I get in the boost all 18 lbs. of it I want from a AFR of 12.2 ish to the AFR of like 10.4 and sometimes at like 4000 it will even drop into the 9.8 range. So the good news is I have it pretty much running awesome, and the good news is I will have to make some passes down the street and dial in my AFR for the track on the 2nd. Sorry such a long read, but I hopes it helps someone

  20. #95
    FEP Super Member PaceFever79's Avatar
    Join Date
    Feb 2009
    Location
    Western PA
    Posts
    9,618

    Default 1984 project SVO

    Oops wrong thread!

  21. #96
    FEP Member bad82gt's Avatar
    Join Date
    Dec 2009
    Location
    Oklahoma City, OK
    Posts
    119

    Default

    I wouldnt suppose you bought this car near Santa Barbara/Carpinteria by chance?
    1980 Cobra - bone stock
    1982 GT - Under construction
    1984 SVO - "Outlaw" Edition (not sure what that means, yet)
    1986 GT - 302/T5, mostly original, 55,000 original miles
    1990 Bronco - 357/AOD/GT40 converted/MAF converted/SEFI converted, long travel suspension to be installed soon

  22. #97
    FEP Member Ford Builder's Avatar
    Join Date
    Nov 2008
    Location
    Chatham Ont Canada
    Posts
    409

    Default

    Keep us posted on your progress.
    IF ITS FORD POWERED YOU GOT TO LOVE IT

  23. #98

  24. #99

    Default

    Quote Originally Posted by quickerstang View Post
    So I wanted a bigger intercooler and decided on the NPR. Here is a pic next to the stock radiator


    I went with the supercoupe radiator and fan for cooling


    for piping I went with stingers NPR/volvo kit
    I know this is a really old thread and the original poster may no longer be on the board but wanted to see if anyone knows what year super Coupe this radiator is from and if the original air conditioning could have been preserved with the addition of this NPR intercooler. I have this same intercooler on the shelf a day I've been toying in my mind on how to make it work.

  25. #100

    Default

    Quote Originally Posted by foot2floor View Post
    I know this is a really old thread and the original poster may no longer be on the board but wanted to see if anyone knows what year super Coupe this radiator is from and if the original air conditioning could have been preserved with the addition of this NPR intercooler. I have this same intercooler on the shelf a day I've been toying in my mind on how to make it work.
    Don't know anything about the AC but the Supercoupe only existed in one single bodystyle over a 6 year run. There should only be one radiator.

Page 4 of 4 FirstFirst ... 234

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •